#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).*(https:\/\/cloud\.saikoanimes\.net\/.*)" c.*"
Local $sString = "" & @CRLF & _
" <a href="https://cloud.saikoanimes.net/11Yu" class="btn-sa" target="blank">01</a>" & @CRLF & _
"<a href="https://cloud.saikoanimes.net/BXz" class="btn-sa" target="blank">02</a>" & @CRLF & _
"<a href="https://cloud.saikoanimes.net/BXv" class="btn-sa" target="blank">03</a>" & @CRLF & _
"<a href="https://cloud.saikoanimes.net/11Yx" class="btn-sa" target="blank">04</a>" & @CRLF & _
"<a href="https://cloud.saikoanimes.net/BXt" class="btn-sa" target="blank">05</a>" & @CRLF & _
"<a href="https://cloud.saikoanimes.net/BXw" class="btn-sa" target="blank">06</a>" & @CRLF & _
"<a href="https://cloud.saikoanimes.net/11Yv" class="btn-sa" target="blank">07</a>" & @CRLF & _
"<a href="https://cloud.saikoanimes.net/BXx" class="btn-sa" target="blank">08</a>" & @CRLF & _
"<a href="https://cloud.saikoanimes.net/BXy" class="btn-sa" target="blank">09</a>" & @CRLF & _
"<a href="https://cloud.saikoanimes.net/11Yo" class="btn-sa" target="blank">10</a>" & @CRLF & _
"<a href="https://cloud.saikoanimes.net/11Ym" class="btn-sa" target="blank">11</a>" & @CRLF & _
"<a href="https://cloud.saikoanimes.net/11Yw" class="btn-sa final" target="blank">12</a> "
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)