re = /(< [\d.]{1,5})|([\d.]{1,5} - [\d.]{1,5})|(>= [\d.]{1,5})/
str = '< 6
7.44 - 17
>= 18'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end