import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(< [\\d.]{1,5})|([\\d.]{1,5} - [\\d.]{1,5})|(>= [\\d.]{1,5})";
final String string = "< 6\n"
+ "7.44 - 17\n"
+ ">= 18";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}