using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(< [\d.]{1,5})|([\d.]{1,5} - [\d.]{1,5})|(>= [\d.]{1,5})";
string input = @"< 6
7.44 - 17
>= 18";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}