$re = '/(< [\d.]{1,5})|([\d.]{1,5} - [\d.]{1,5})|(>= [\d.]{1,5})/';
$str = '< 6
7.44 - 17
>= 18';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);