re = /(?:\/(C|ST|L|O|OU|CN|emailAddress)=([^\/]+))?/
str = '/C=DE/ST=Niedersachsen/L=Hannover/O=My Company Inc./OU=Coffee Department/CN=www.example.com/emailAddress=nobody@example.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end