using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\/(C|ST|L|O|OU|CN|emailAddress)=([^\/]+))?";
string input = @"/C=DE/ST=Niedersachsen/L=Hannover/O=My Company Inc./OU=Coffee Department/CN=www.example.com/emailAddress=nobody@example.com";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}