$re = '/(?:\/(C|ST|L|O|OU|CN|emailAddress)=([^\/]+))?/';
$str = '/C=DE/ST=Niedersachsen/L=Hannover/O=My Company Inc./OU=Coffee Department/CN=www.example.com/emailAddress=nobody@example.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);