#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\/(C|ST|L|O|OU|CN|emailAddress)=([^\/]+))?"
Local $sString = "/C=DE/ST=Niedersachsen/L=Hannover/O=My Company Inc./OU=Coffee Department/CN=www.example.com/emailAddress=nobody@example.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")