import Foundation
let pattern = #"(?:(?:[^\s\d\x2e]+[\s\d\x2e]*)|(?:[\x2e\s\d]*[^\s\x2e\d]+))[\r\n]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
2222.22.22.22
asd
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}