// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:(?:[^\s\d\x2e]+[\s\d\x2e]*)|(?:[\x2e\s\d]*[^\s\x2e\d]+))[\r\n]").unwrap();
let string = "2222.22.22.22
asd";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}