import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?:[^\\s\\d\\x2e]+[\\s\\d\\x2e]*)|(?:[\\x2e\\s\\d]*[^\\s\\x2e\\d]+))[\\r\\n]";
final String string = "2222.22.22.22\n"
+ "asd";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}