package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:(?:[^\s\d\x2e]+[\s\d\x2e]*)|(?:[\x2e\s\d]*[^\s\x2e\d]+))[\r\n]`)
var str = `2222.22.22.22
asd`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}