re = /(?i)(CHE-\d{3}\.\d{3}\.\d{3}\ +(IVA|TVA|MWST))/
str = 'CHE-123.456.789 MWST
CHE-123.456.789 TVA
CHE-123.456.789 IVA
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end