#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(CHE-\d{3}\.\d{3}\.\d{3}\ +(IVA|TVA|MWST))"
Local $sString = "CHE-123.456.789 MWST" & @CRLF & _
"CHE-123.456.789 TVA" & @CRLF & _
"CHE-123.456.789 IVA" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")