using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(CHE-\d{3}\.\d{3}\.\d{3}\ +(IVA|TVA|MWST))";
string input = @"CHE-123.456.789 MWST
CHE-123.456.789 TVA
CHE-123.456.789 IVA
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}