$re = '/(?i)(CHE-\d{3}\.\d{3}\.\d{3}\ +(IVA|TVA|MWST))/';
$str = 'CHE-123.456.789 MWST
CHE-123.456.789 TVA
CHE-123.456.789 IVA
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);