// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"^(_{2}\([\'\"]{1})([a-zA-Z1-9\s%\_\'\.\,(\"\))*\(\=\>\$\-\!]*[(\){1,3})*(\'\)*)(\){1,3})*(\"\))*]+)"#).unwrap();
let string = "__('Register and apply for %job_title%', array('%job_title%' => $job->getTitle()));
__(\"Invalid File\".$something.\" Extension\");
__(\"Employers9\");
_sometime
__('Please read the Privacy Policy and tick $the %ceva%box to say you have done so.!')
__('Register and apply for %job_title%', array('%job_title%' => $job->getTitle()))
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}