use strict;
my $str = '__(\'Register and apply for %job_title%\', array(\'%job_title%\' => $job->getTitle()));
__("Invalid File".$something." Extension");
__("Employers9");
_sometime
__(\'Please read the Privacy Policy and tick $the %ceva%box to say you have done so.!\')
__(\'Register and apply for %job_title%\', array(\'%job_title%\' => $job->getTitle()))
';
my $regex = qr/^(_{2}\([\'\"]{1})([a-zA-Z1-9\s%\_\'\.\,(\"\))*\(\=\>\$\-\!]*[(\){1,3})*(\'\)*)(\){1,3})*(\"\))*]+)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}