# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(_{2}\([\'\"]{1})([a-zA-Z1-9\s%\_\'\.\,(\"\))*\(\=\>\$\-\!]*[(\){1,3})*(\'\)*)(\){1,3})*(\"\))*]+)"
test_str = ("__('Register and apply for %job_title%', array('%job_title%' => $job->getTitle()));\n"
"__(\"Invalid File\".$something.\" Extension\");\n"
"__(\"Employers9\");\n"
"_sometime\n\n"
"__('Please read the Privacy Policy and tick $the %ceva%box to say you have done so.!')\n\n\n\n\n"
"__('Register and apply for %job_title%', array('%job_title%' => $job->getTitle())) \n"
" \n\n")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.