re = /^(_{2}\([\'\"]{1})([a-zA-Z1-9\s%\_\'\.\,(\"\))*\(\=\>\$\-\!]*[(\){1,3})*(\'\)*)(\){1,3})*(\"\))*]+)/
str = '__(\'Register and apply for %job_title%\', array(\'%job_title%\' => $job->getTitle()));
__("Invalid File".$something." Extension");
__("Employers9");
_sometime
__(\'Please read the Privacy Policy and tick $the %ceva%box to say you have done so.!\')
__(\'Register and apply for %job_title%\', array(\'%job_title%\' => $job->getTitle()))
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end