$re = '/@((\s*\w+){1,2})\b/';
$str = '@ ricky jiao test a a @tracy liu';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);