const regex = /@((\s*\w+){1,2})\b/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('@((\\s*\\w+){1,2})\\b', '')
const str = `@ ricky jiao test a a @tracy liu`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}