using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@((\s*\w+){1,2})\b";
string input = @"@ ricky jiao test a a @tracy liu";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}