package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`@((\s*\w+){1,2})\b`)
var str = `@ ricky jiao test a a @tracy liu`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}