re = /.*(\d+).*/
str = 'CTRL_RADIOCOLUMNS_1
CTRL_RADIOCOLUMNS_22
CTRL_RADIOCOLUMNS_333
CTRL_RADIOCOLUMNS_4444'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end