$re = '/.*(\d+).*/';
$str = 'CTRL_RADIOCOLUMNS_1
CTRL_RADIOCOLUMNS_22
CTRL_RADIOCOLUMNS_333
CTRL_RADIOCOLUMNS_4444';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);