import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*(\\d+).*";
final String string = "CTRL_RADIOCOLUMNS_1\n"
+ "CTRL_RADIOCOLUMNS_22\n"
+ "CTRL_RADIOCOLUMNS_333\n"
+ "CTRL_RADIOCOLUMNS_4444";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}