#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*(\d+).*"
Local $sString = "CTRL_RADIOCOLUMNS_1" & @CRLF & _
"CTRL_RADIOCOLUMNS_22" & @CRLF & _
"CTRL_RADIOCOLUMNS_333" & @CRLF & _
"CTRL_RADIOCOLUMNS_4444"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")