$re = '/^(?=.{6,20})(?=(?:.*\d){2,})(?=.*[A-Z]+).*$/m';
$str = '# Validar contraseñas.
# Comprueba que la contraseña tiene más de 6 caracteres.
# Comprueba que la contraseña tiene como mínimo 2 números.
# Comprueba que la contraseña tiene un caracter en mayuscula.
# Contraseñas válidas
4Buhos3programando
prueba21Pass
# Contraseña no válidas
# No tiene mayusculas
contraseña22
# No tiene números
Contraseña.
# Es demasiado corta
33A22
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);