import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{6,20})(?=(?:.*\\d){2,})(?=.*[A-Z]+).*$";
final String string = "# Validar contraseñas.\n"
+ "# Comprueba que la contraseña tiene más de 6 caracteres.\n"
+ "# Comprueba que la contraseña tiene como mínimo 2 números.\n"
+ "# Comprueba que la contraseña tiene un caracter en mayuscula.\n\n"
+ "# Contraseñas válidas\n"
+ "4Buhos3programando\n"
+ "prueba21Pass\n\n"
+ "# Contraseña no válidas\n\n"
+ "# No tiene mayusculas\n"
+ "contraseña22\n"
+ "# No tiene números\n"
+ "Contraseña.\n"
+ "# Es demasiado corta\n"
+ "33A22\n\n\n\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}