using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.{6,20})(?=(?:.*\d){2,})(?=.*[A-Z]+).*$";
string input = @"# Validar contraseñas.
# Comprueba que la contraseña tiene más de 6 caracteres.
# Comprueba que la contraseña tiene como mínimo 2 números.
# Comprueba que la contraseña tiene un caracter en mayuscula.
# Contraseñas válidas
4Buhos3programando
prueba21Pass
# Contraseña no válidas
# No tiene mayusculas
contraseña22
# No tiene números
Contraseña.
# Es demasiado corta
33A22
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}