#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.{6,20})(?=(?:.*\d){2,})(?=.*[A-Z]+).*$"
Local $sString = "# Validar contraseñas." & @CRLF & _
"# Comprueba que la contraseña tiene más de 6 caracteres." & @CRLF & _
"# Comprueba que la contraseña tiene como mínimo 2 números." & @CRLF & _
"# Comprueba que la contraseña tiene un caracter en mayuscula." & @CRLF & _
"" & @CRLF & _
"# Contraseñas válidas" & @CRLF & _
"4Buhos3programando" & @CRLF & _
"prueba21Pass" & @CRLF & _
"" & @CRLF & _
"# Contraseña no válidas" & @CRLF & _
"" & @CRLF & _
"# No tiene mayusculas" & @CRLF & _
"contraseña22" & @CRLF & _
"# No tiene números" & @CRLF & _
"Contraseña." & @CRLF & _
"# Es demasiado corta" & @CRLF & _
"33A22" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")