import Foundation
let pattern = #"@import\s*(url)?\s*\(?([^;]+?)\)?;"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = ##"""
@import url(comments.css);
body{
margin: 0px;
padding: 0px;
background: #FFFFFF;
font: normal small "Trebuchet MS", Arial, Helvetica, sans-serif;
color: #777777;
}
@import "/style/main.css" screen; /* Стиль Ð´Ð»Ñ Ð²Ñ‹Ð²Ð¾Ð´Ð° результата на монитор */
@import "/style/palm.css" handheld, print; /* Стиль Ð´Ð»Ñ Ð¿ÐµÑ‡Ð°Ñ‚Ð¸ *
@import url("style-1024.css") screen and (min-width: 1000px) and (max-width: 1279px);
@import url("style-1280.css") screen and (min-width: 1280px) and (max-width: 1300px);
@import url("style-1366.css") screen and (min-width: 1301px) and (max-width: 1900px);
@import url("style-1366.css") screen and (min-width: 1901px);
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)