using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@import\s*(url)?\s*\(?([^;]+?)\)?;";
string input = @"@import url(comments.css);
body{
margin: 0px;
padding: 0px;
background: #FFFFFF;
font: normal small ""Trebuchet MS"", Arial, Helvetica, sans-serif;
color: #777777;
}
@import ""/style/main.css"" screen; /* Стиль Ð´Ð»Ñ Ð²Ñ‹Ð²Ð¾Ð´Ð° результата на монитор */
@import ""/style/palm.css"" handheld, print; /* Стиль Ð´Ð»Ñ Ð¿ÐµÑ‡Ð°Ñ‚Ð¸ *
@import url(""style-1024.css"") screen and (min-width: 1000px) and (max-width: 1279px);
@import url(""style-1280.css"") screen and (min-width: 1280px) and (max-width: 1300px);
@import url(""style-1366.css"") screen and (min-width: 1301px) and (max-width: 1900px);
@import url(""style-1366.css"") screen and (min-width: 1901px);";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}