package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)@import\s*(url)?\s*\(?([^;]+?)\)?;`)
var str = `@import url(comments.css);
body{
margin: 0px;
padding: 0px;
background: #FFFFFF;
font: normal small "Trebuchet MS", Arial, Helvetica, sans-serif;
color: #777777;
}
@import "/style/main.css" screen; /* Стиль Ð´Ð»Ñ Ð²Ñ‹Ð²Ð¾Ð´Ð° результата на монитор */
@import "/style/palm.css" handheld, print; /* Стиль Ð´Ð»Ñ Ð¿ÐµÑ‡Ð°Ñ‚Ð¸ *
@import url("style-1024.css") screen and (min-width: 1000px) and (max-width: 1279px);
@import url("style-1280.css") screen and (min-width: 1280px) and (max-width: 1300px);
@import url("style-1366.css") screen and (min-width: 1301px) and (max-width: 1900px);
@import url("style-1366.css") screen and (min-width: 1901px);`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}