# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"@import\s*(url)?\s*\(?([^;]+?)\)?;"
test_str = ("@import url(comments.css);\n"
"body{\n"
" margin: 0px;\n"
" padding: 0px;\n"
" background: #FFFFFF;\n"
" font: normal small \"Trebuchet MS\", Arial, Helvetica, sans-serif;\n"
" color: #777777;\n"
"}\n"
"@import \"/style/main.css\" screen; /* Стиль Ð´Ð»Ñ Ð²Ñ‹Ð²Ð¾Ð´Ð° результата на монитор */\n"
"@import \"/style/palm.css\" handheld, print; /* Стиль Ð´Ð»Ñ Ð¿ÐµÑ‡Ð°Ñ‚Ð¸ *\n\n"
"@import url(\"style-1024.css\") screen and (min-width: 1000px) and (max-width: 1279px);\n"
"@import url(\"style-1280.css\") screen and (min-width: 1280px) and (max-width: 1300px);\n"
"@import url(\"style-1366.css\") screen and (min-width: 1301px) and (max-width: 1900px);\n"
"@import url(\"style-1366.css\") screen and (min-width: 1901px);")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.