import Foundation
let pattern = #"^(.+?)\. Last message: (.+\.?) (\w[^AMP].+?)\.$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
Sandy Smith. Last message: Will do! 2/2/17.
Caroline Doe. Last message: I will definitely tell him to come! Thank you so much for checking up on the both of us 2/2/17.
thundercall@ecnetwork.com. Last message: (Alert) CodeRED Weather Warning: The NWS has issued a Severe Thunderstorm Warning for your WALTHAM ST location from 8:00 AM April 30 until 8:30 AM April 3 4/30/16.
BFristN BLastN. Last message: Okay, I figured it out. Will post on the forum in a sec. 4:25 PM.
BFristN BLastN. Last message: Okay, I figured it out. Will post on the forum in a sec. Yesterday.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)