using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.+?)\. Last message: (.+\.?) (\w[^AMP].+?)\.$";
string input = @"Sandy Smith. Last message: Will do! 2/2/17.
Caroline Doe. Last message: I will definitely tell him to come! Thank you so much for checking up on the both of us 2/2/17.
thundercall@ecnetwork.com. Last message: (Alert) CodeRED Weather Warning: The NWS has issued a Severe Thunderstorm Warning for your WALTHAM ST location from 8:00 AM April 30 until 8:30 AM April 3 4/30/16.
BFristN BLastN. Last message: Okay, I figured it out. Will post on the forum in a sec. 4:25 PM.
BFristN BLastN. Last message: Okay, I figured it out. Will post on the forum in a sec. Yesterday.
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}