#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(.+?)\. Last message: (.+\.?) (\w[^AMP].+?)\.$"
Local $sString = "Sandy Smith. Last message: Will do! 2/2/17." & @CRLF & _
"" & @CRLF & _
"Caroline Doe. Last message: I will definitely tell him to come! Thank you so much for checking up on the both of us 2/2/17." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"thundercall@ecnetwork.com. Last message: (Alert) CodeRED Weather Warning: The NWS has issued a Severe Thunderstorm Warning for your WALTHAM ST location from 8:00 AM April 30 until 8:30 AM April 3 4/30/16." & @CRLF & _
"" & @CRLF & _
"BFristN BLastN. Last message: Okay, I figured it out. Will post on the forum in a sec. 4:25 PM." & @CRLF & _
"" & @CRLF & _
"BFristN BLastN. Last message: Okay, I figured it out. Will post on the forum in a sec. Yesterday." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")