use strict;
my $str = 'Sandy Smith. Last message: Will do! 2/2/17.
Caroline Doe. Last message: I will definitely tell him to come! Thank you so much for checking up on the both of us 2/2/17.
thundercall@ecnetwork.com. Last message: (Alert) CodeRED Weather Warning: The NWS has issued a Severe Thunderstorm Warning for your WALTHAM ST location from 8:00 AM April 30 until 8:30 AM April 3 4/30/16.
BFristN BLastN. Last message: Okay, I figured it out. Will post on the forum in a sec. 4:25 PM.
BFristN BLastN. Last message: Okay, I figured it out. Will post on the forum in a sec. Yesterday.
';
my $regex = qr/^(.+?)\. Last message: (.+\.?) (\w[^AMP].+?)\.$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}