// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(TIM[\d]{4}-[\d]+ [|]) ([\d]{6}[.][\w]+[/d]*) ([\w]+-?\d*)(.*)").unwrap();
let string = "TIM2020-001 | 200224.T7 Ia-8
TIM2020-001 | 200224.T7 Gr
TIM2020-001 | 200224.T77 Gr
TIM2020-001 | 20024.T7 Gr";
let substitution = "$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}