use strict;
my $str = 'TIM2020-001 | 200224.T7 Ia-8
TIM2020-001 | 200224.T7 Gr
TIM2020-001 | 200224.T77 Gr
TIM2020-001 | 20024.T7 Gr';
my $regex = qr/(TIM[\d]{4}-[\d]+ [|]) ([\d]{6}[.][\w]+[/d]*) ([\w]+-?\d*)(.*)/mp;
my $subst = '$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";