const regex = /(TIM[\d]{4}-[\d]+ [|]) ([\d]{6}[.][\w]+[/d]*) ([\w]+-?\d*)(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(TIM[\\d]{4}-[\\d]+ [|]) ([\\d]{6}[.][\\w]+[\/d]*) ([\\w]+-?\\d*)(.*)', 'gm')
const str = `TIM2020-001 | 200224.T7 Ia-8
TIM2020-001 | 200224.T7 Gr
TIM2020-001 | 200224.T77 Gr
TIM2020-001 | 20024.T7 Gr`;
const subst = `$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);