# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(TIM[\d]{4}-[\d]+ [|]) ([\d]{6}[.][\w]+[\/d]*) ([\w]+-?\d*)(.*)/$3/gm;t' <<< "TIM2020-001 | 200224.T7 Ia-8
TIM2020-001 | 200224.T7 Gr
TIM2020-001 | 200224.T77 Gr
TIM2020-001 | 20024.T7 Gr"