re = /^[a-zA-Z0-9äöüß.!#$%&’*+\/=?^_`{|}~-]+@[a-zA-Z0-9-äöüß]+(?:\.[a-zA-Z0-9-äöüß]+)*$/m
str = 'a@b
max.mustermann@bahn.de
team-ümlaut@test.com
stußmail@ümlaut.tülüdü
_@test.de
@.de
.@.
ohneATgehtnix.de
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end