using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z0-9äöüß.!#$%&’*+/=?^_`{|}~-]+@[a-zA-Z0-9-äöüß]+(?:\.[a-zA-Z0-9-äöüß]+)*$";
string input = @"a@b
max.mustermann@bahn.de
team-ümlaut@test.com
stußmail@ümlaut.tülüdü
_@test.de
@.de
.@.
ohneATgehtnix.de
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}