const regex = /^[a-zA-Z0-9äöüß.!#$%&’*+/=?^_`{|}~-]+@[a-zA-Z0-9-äöüß]+(?:\.[a-zA-Z0-9-äöüß]+)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z0-9äöüß.!#$%&’*+\/=?^_`{|}~-]+@[a-zA-Z0-9-äöüß]+(?:\\.[a-zA-Z0-9-äöüß]+)*$', 'gm')
const str = `a@b
max.mustermann@bahn.de
team-ümlaut@test.com
stußmail@ümlaut.tülüdü
_@test.de
@.de
.@.
ohneATgehtnix.de
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}