import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z0-9äöüß.!#$%&’*+/=?^_`\\{|\\}~-]+@[a-zA-Z0-9-äöüß]+(?:\\.[a-zA-Z0-9-äöüß]+)*$";
final String string = "a@b\n"
+ "max.mustermann@bahn.de\n"
+ "team-ümlaut@test.com\n"
+ "stußmail@ümlaut.tülüdü\n"
+ "_@test.de\n"
+ "@.de\n"
+ ".@.\n"
+ "ohneATgehtnix.de\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}