// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mu)(\w+,)*(\w+)\s+(\w+\d{6},)*(\w*\d{6})").unwrap();
let string = "山东大学古籍所,山东大学古籍所,山东 大学古籍所,山东大学古籍所 山东济南250100,山东济南250100,山东济南250100,山东济南250100";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}